28 lines
882 B
Bash
28 lines
882 B
Bash
# Maintainer: 0xDEADCADE <$(base64 -d<<<MHhkZWFkY2FkZUBwcm90b25tYWlsLmNvbQ==)>
|
|
pkgname=headsetcontrol-chatmixd-git
|
|
_pkgname=${pkgname%-git}
|
|
pkgver=r1.2cab32f
|
|
pkgrel=1
|
|
pkgdesc="A bash daemon to control volume of different applications through the Chatmix wheel."
|
|
arch=('any')
|
|
url="https://github.com/0xDEADCADE/${_pkgname}"
|
|
license=('GPLv3')
|
|
provides=("$_pkgname")
|
|
conflicts=("$_pkgname")
|
|
depends=('bash' 'bc' 'headsetcontrol' 'pipewire' 'libpulse')
|
|
optdepends=('helvum')
|
|
makedepends=('git')
|
|
source=("$pkgname::git+${url}.git")
|
|
md5sums=('SKIP')
|
|
|
|
pkgver() {
|
|
cd $pkgname
|
|
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
|
|
}
|
|
|
|
package() {
|
|
cd $pkgname
|
|
install -D -m755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
|
|
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
|
|
install -D -m644 "${_pkgname}.service" "$pkgdir/usr/lib/systemd/user/"
|
|
}
|